Jump to content

Batterie S18 et BMS


APLUfr
 Share

Recommended Posts

Pour ceux que ça intéressent petite analyse rapide des BMS et des packs de batteries de la S18

- tous les packs sont équipés de cellules INR21700M50T de chez LG (on peut trouver les specs ici : inr21700m50t_lg.pdf)
- on a 2 packs de 20S et 2 packs de 10S

Concernant le connecteurs sur tous les packs sauf un on retrouve ce montage là :

xt90i.thumb.jpg.42a3fec663d4ea63a616d743543237da.jpg

Avec:

- B+ et B- qui correspondent au 72V (60V - 84V)
- C- et C+ qui correspondent à la tension de signalétique pour la CM qui varie a priori entre 10 et 12V (11.84V pour 84.34V ; 10.87V pour environ 73V, la tension pour 60V n’a pas été mesuré…).

A noter C- et B- sont réunis ensemble, sauf sur un pack de 10S il n’y a que le C+

Les packs de batteries 20S

20s_bms.thumb.jpg.8d00351bcceca8f374e4477bde5c0118.jpg

On a une borne de test qui permet de mesurer la valeur de chaque cellule individuellement (rouge), puis une partie équilibrage en bleu.

Lorsque la tension de la cellule arrive autour 4.216 - 4.2V la partie shunt s’active, facile a voir il y’a une led rouge par batterie lorsque c’est actif (le pack de droite en a quelques une allumées)

La partie shunt se fait par un résistance SMD de 100ohms, par contre impossible de savoir le composant qui assure la régulation

PXL_20211230_090129112.thumb.jpg.921a646fdbd3c15ebfe75b4f862ab98a.jpg

 

Cette partie là je n’ai pas réussi a savoir l’usage, probablement une partie mesure de l’état de charge pour envoyer l’info sur le signal C-/C+

 

PXL_20211230_090153212.thumb.jpg.1c07983cd54a68d9694d61bd8336f5ce.jpg

 

Il y’a aussi cette partie est situé tout en haut, côté connecteur :

PXL_20211230_090159181.thumb.jpg.7c72b26a4b761f103ce11b48fe42eae3.jpg

Les "Z" à droite sont des fusibles (valeur inconnu, 5A ?), les autres composants on a pas compris l’utilité, il y’a 12.87V entre le "moins" et une des broches.

Pour les packs en 10S le montage est similaire (n’ayant pas la roue a proximité je ne serai pas dire lequel va a droite et lequel a gauche)

On retrouve un premier pack avec les bornes de tests, et la partie équilibrage, on notera que les bornes de test sur ce pack vont de b- (b0) à b10

10s_bms_b1.thumb.jpg.9583c76dcfc6b170a77d85ddeaba2e08.jpg

l'autre pack lui les bornes vont de B10 à B+ (B20) et ne possède qu’un seul fil de contrôle C+ (par contre la tension se mesure différemment)

10s_bms_b2.thumb.jpg.a2e2f7e94962a0ccd09f0e490c209d91.jpg

Cette petite subtilité permet de savoir comment brancher les packs en série hors de la roue ;)

Côté équilibrage, lorsque les batteries ont été ouvertes elles étaient a environ 50% de charge avec une tension de 3.648V ±0.002V, une fois chargé à 100% on mesure 4.218V à ±0.01V (mais l’équilibrage n’est pas complètement fini les leds clignotent encore un peu sur certains packs)

Pour des raisons de temps on a pas mesurer la capacité réelle des packs (pour ça il faut déchargé avec un appareil de mesure a courant constant, on avait a dispo mais pas le temps :))

 

En tout cas c’est bien fait et pour citer la personne qui était avec moi a ce moment là « c’est carrément mieux foutu que sur les packs des VAE  (sur les VAE ils font souvent du 4p10s (4 cellules en parallèles puis mise en série… petite subtilité… qui se remarque quand une cellule est HS) ».

 

  • Like 9
  • Thanks 2
Link to comment
Share on other sites

6 hours ago, fr4bd said:

Juste pour complément d'info : les connecteurs sont des XT90i

Yes, j’ai oublié de le mentionner !

6 hours ago, fr4bd said:

Merci pour ces observations fort utiles 👍 Vivement la procédure de rééquilibrage de cellule 😉

A priori si le bms fonctionne, rien de spécial… laisser chargé à 100% et attendre. L’équilibrage ne peut pas se faire si la batterie n’est pas chargé à 100%

Si on a un chargeur qui affiche tension & intensité lorsqu’on est entre 84V et 84.5V une fois l’intensité a moins de 40-50mA par pack la charge est terminé et l’équilibrage se fait automatiquement (avec les 3 packs ont a autour de 150mA et je n’ai aucune idée de la consommation de la carte mère).

Sauf mauvaise interprétation des pistes, le BMS ne cherche pas a équilibrer la tension entre chacune des cellules (genre un seul circuit pour mesurer la tension et avoir toutes les cellules à la même tension), chaque cellule à individuellement a son propre circuit de régulation et la carte mère n’a aucune retour de l’état individuel des cellules).

Link to comment
Share on other sites

Je viens de voir cette autre sujet qui parle aussi des batteries de la S18 (avec la recherche pourri du forum je ne l’avais pas vu initialement).

Précision aussi : tous les composants sont recouvert par une couche de verni pour évider humidité et oxydation.

Link to comment
Share on other sites

On 12/30/2021 at 6:42 PM, APLUfr said:

Sauf mauvaise interprétation des pistes, le BMS ne cherche pas a équilibrer la tension entre chacune des cellules (genre un seul circuit pour mesurer la tension et avoir toutes les cellules à la même tension),

J'ai comme un doute ... Pardonne mon ignorance, mais à moins de vouloir limiter le rôle du BMS à celui de 'moniteur' et non de gestionnaire ('management'), à quoi pourrait alors servir un tel système ? Qu'entends-tu par «mauvaise interprétation des pistes» ? Pour moi le BMS  permet bel et bien l'équilibrage des cellules, sauf défaillance provoquée, par exemple, par un excès de charges incomplètes.

Ma seule référence pour l'instant est la définition de Wikipedia :

Quote

A battery management system (BMS) is any electronic system that manages a rechargeable battery (cell or battery pack), such as by protecting the battery from operating outside its safe operating area, monitoring its state, calculating secondary data, reporting that data, controlling its environment, authenticating it and / or balancing it.

Edited by fr4bd
Link to comment
Share on other sites

4 hours ago, fr4bd said:

J'ai comme un doute ... Pardonne mon ignorance, mais à moins de vouloir limiter le rôle du BMS à celui de 'moniteur' et non de gestionnaire ('management'), à quoi pourrait alors servir un tel système ? Qu'entends-tu par «mauvaise interprétation des pistes» ? Pour moi le BMS  permet bel et bien l'équilibrage des cellules, sauf défaillance provoquée, par exemple, par un excès de charges incomplètes.

Ma seule référence pour l'instant est la définition de Wikipedia :

Ce que je veux, en analysant au maximum de ce que je peux sans dessouder les batteries, chaque cellule possède son propre circuit de régulation qui mesure la tension au borne de la cellule et active ou pas la résistance de 100 ohms si la tension mesuré dépasse les 4.21V.

Mais cette mesure est propre a chaque cellule et il n’y pas une puce "intelligente" qui s’assure que la tension de toutes les cellules sont exactement la même (et qui pourrai activer ou commencer un équilibrage avant d’être à 100%).

Le montage n’est pas mauvais et fonctionne, a condition de laisser la batterie chargé à 100% jusqu’à ce que toutes les leds rouge soient allumés (ce qui n’est pas visible lorsqu’elle sont dans le bloc en alu sur la roue). Il a l’avantage d’être facile a modifier en fonction du nombre cellule vu qu’on a un circuit indépendant a chaque fois il y’a juste a faire des copier / coller et espérer que le logiciel de routage de piste sur PCB s’en sorte :)

 

Comme la testé @Cormo dans l’autre sujet (pas celui où il fait des cours circuits ;)), un excès de charge incomplète (ce qui revient à déséquilibrer le pack) n’empêche pas un équilibrage mais par contre ça prend du temps, dès qu’une cellule arrive à 4.21V les autres cellules vont être chargé au mieux à 42mA ...

 

Link to comment
Share on other sites

Posted (edited)

Pour donner une idée voici le circuit électronique qui fait l’équilibrage d’une cellule :

La valeur du condensateur et de la résistance pour la diode sont illisible, j’ai supposé un transistor NPN mais c’est sûrement un mosfet.

Le composant "U1" compare la tension aux bornes (ici 5 et 6) et si la tension est supérieure elle laisse passer une tension dans le transistor qui "vide/by pass" la batterie dans une résistance de 100ohms et dans une led.

balance.png

Le schéma ne correspond pas exactement à la réalité sur les valeurs des composants ou le brochage de U1, j’ai fais "schéma" rapidement avec un logiciel de dessin pour le principe de fonctionnement.

Edited by APLUfr
Link to comment
Share on other sites

  • 5 months later...
Posted (edited)

Bonjour,

J'ai la batterie droite de ma S18 qui refuse de se charger.
Sur le BMS, je mesure 81,2V sur les pins de mesures dédiées et 70V sur le connecteur jaune.

Sur les pins C+ et C-, aucune tension.
Au niveau de C-, il y a une diode US2G et je mesure 81,2V sur la cathode (-).

Pour aider un électronicien qui pourrait trouver la solution, j'ai recherché le datasheet du Contrôleur de charge présent sur BMS de la KingSong KS-S18 _ le NEOTEC NT166xA pour les batteries de 360Wh.


Quelqu'un aurait-il une idée pourquoi la tension de contrôle de charge qui devrait être de 12V en pleine charge est absente sur le connecteur jaune ?
 

xt90i.thumb.jpg.42a3fec663d4ea63a616d743543237da.jpg

IMG_20220604_121416.jpg

Contrôleur de charge BMS KingSong KS-S18 _ NEOTEC NT166xA.jpg

IMG_20220604_150453.jpg

Contrôleur de charge NT166xA_DS_V1.04_1.pdf

Edited by exosteph
Link to comment
Share on other sites

Lorsque j'ai réparé ma batterie je me suis retrouvé dans une situation plus ou moins similaire, avec une tension différente sur le connecteur de celle mesurée directement sur les cellules.

Je n'en ai pas trouvé la raison.

Tout est rentré dans l'ordre lorsque j'ai branché un chargeur en direct sur le connecteur sans passer par la CM.

Link to comment
Share on other sites

il y a une heure, Cormo a dit :

Lorsque j'ai réparé ma batterie je me suis retrouvé dans une situation plus ou moins similaire, avec une tension différente sur le connecteur de celle mesurée directement sur les cellules.

Je n'en ai pas trouvé la raison.

Tout est rentré dans l'ordre lorsque j'ai branché un chargeur en direct sur le connecteur sans passer par la CM.

En direct ? Tu as soudé des fils, comment as-tu fait ?

Link to comment
Share on other sites

J'ai un peu joué les apprentis-sorciers... Le câble de mon chargeur avait une prise intermédiaire "T connector" permettant de relier avec de simples fils.

Il faut faire gaffe, le 84V ça commence à faire de belles étincelles.

As-tu mesuré chacune des cellules individuellement pour voir s'il n'y en a pas une très déchargée par rapport aux autres ?

Link to comment
Share on other sites

oui j'ai mesuré toutes les cellules individuellement et elles sont toutes à 4,02V

Les 4 batteries ont été changées, il y a 1 mois... 

C'est abusé ces problèmes de batteries sur la S18, ça fait 3 fois que je la change.

Je vais tenter ta méthode de liaison directe.

Link to comment
Share on other sites

Étant donné que le chargeur refuse de charger la batterie lorsqu'elle est montée sur la roue, j'ai suivi le conseil de Cormo.

J'ai démonté le chargeur KingSong pour souder 2 fils dessus et les relier directement sur la batterie et ça charge !

J'ai mis un ampèremètre en série pour vérifier le courant de charge et c'est correct, c'est en fin de charge à 70mA.

À voir si une fois la batterie remontée sur la gyro, si le chargeur acceptera de la charger de nouveau.

Je vous tiens au courant 😉 

IMG_20220604_212227.jpg

IMG_20220604_212248.jpg

IMG_20220604_212325.jpg

IMG_20220604_212334.jpg

  • Like 1
Link to comment
Share on other sites

Il y a 7 heures, APLUfr a dit :

Je n’ai pas souvenir d'avoir les leds à cette endroit s'allumer pendant la charge en direct sur le BMS 🤔

C'est pas le BMS, c'est le chargeur !

Link to comment
Share on other sites

Il y a 11 heures, exosteph a dit :

C'est abusé ces problèmes de batteries sur la S18, ça fait 3 fois que je la change.

Les soucis de batterie, relativement récurrents sur la S18, ne sont pas dus (enfin pas toujours) à la batterie elle-même, mais à la carte mère qui gère la charge de façon désastreuse. Particulièrement avec les versions de firmware antérieure à la 2.09, à partir de laquelle la coupure prématurée de la charge a été (partiellement) corrigée.

La solution, à mon sens, serait de shunter sauvagement la CM entre le connecteur de charge et les 3 connecteurs des batteries. On éliminerait ainsi également le "mode Vampire". Je n'ai jamais pris le temps de mettre ce projet à exécution, j'attends la prochaine panne. So far so good...

Link to comment
Share on other sites

Verdict, ce matin, je suis aller faire un tour pour décharger les batteries et le problème est toujours présent sur le BMS de la batterie avant droite. Pas de tension de contrôle sur C+, C-, ce qui a pour conséquence que le chargeur refuse de charger toutes les batteries lorsque cette batterie est branchée sur la carte mère.
En attendant, je charge la batterie défectueuse en directe sur le chargeur et je la débranche de la carte mère pour charger les autres.

Auriez-vous une solution pour rétablir la tension de contrôle (12V) ?

Link to comment
Share on other sites

Je dois être chanceux, depuis la maj en 2.09 je vois que mes batteries se rechargent à 84v et avec un autre chargeur qui lui donne du 84v en sortie, mesuré avec un ampèremètre, j'ai la même charge. Pourvu que mes batteries ne me lachent pas!!!!1969516369_Screenshot_20220424-234053_EUCWorld.thumb.png.89205a08c639f8e36d18eb22de851d46.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

arrow_upward